I have GIMP 2.7.5 installed on my system (Ubuntu 11.10) and for some reason it didn’t work anymore and when trying to (re)install it i got an error message:
Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installed
It seems that GIMP 2.7.5 does not work with the current glib and gtk in Oneiric.
To fix the problem you need to add the following repositories to your sources list. To add the repositories press the SuperKey and type sources. In the Software Sources window click on the Other Software tab and click on the Add button. To add the repositories copy+paste the following line:
deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main
When added click on the Add button and copy+paste the following line:
deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main
When done close the Software Sources window and run a system update and reboot your system. After the reboot reinstall GIMP 2.7.5 and it should be working again.