Menu Close

A Fix For Gimp 2.7.5 On Ubuntu 11.10

I have GIMP 2.7.5 installed on my system (Ubuntu 11.10) and for some reason it didn’t work anymore and when trying to (re)install it i got an error message:

Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installed

It seems that GIMP 2.7.5 does not work with the current glib and gtk in Oneiric.



To fix the problem you need to add the following repositories to your sources list. To add the repositories press the SuperKey and type sources. In the Software Sources window click on the Other Software tab and click on the Add button. To add the repositories copy+paste the following line:

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

When added click on the Add button and copy+paste the following line:

deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main

When done close the Software Sources window and run a system update and reboot your system. After the reboot reinstall GIMP 2.7.5 and it should be working again.

0 0 votes
Article Rating
Subscribe
Notify of
guest

This site uses Akismet to reduce spam. Learn how your comment data is processed.

11 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Zedbloc
12 years ago

I’ve tried to use GIMP on a regular basis, but I’m a Photoshop guy – I find it painful to use GIMP. I tried and tried to run Photoshop CS4 on Ubuntu…and also failed. I ended up installing a VM with Win7 on it, and installing PS on that VM.

It’s not perfect, but it works.

@zedbloc
Visit zedbloc for interesting and fun stories.

Wade Mealing
Wade Mealing
12 years ago
Reply to  tinuz

Anyone who can’t use GIMP is just making excuses. This guy does it and does a great job with it.

http://photography.outsidethenorm.com/

Wade Mealing
Wade Mealing
12 years ago
Reply to  tinuz

Sorry if that wasn’t clear.

He uses the gimp for his art.

Josh Beauregard
11 years ago
Reply to  Zedbloc

totally off topic

eMirage
12 years ago

deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main

this repository is really instable, I have switched to gnome classic because of gnome shell form this repository is useless (lot of crashes)

if anyone knows another repo for gimp or the stable dependecies without affecting my gnome shell, please help !

another workaround is to find a portable build of gimp with locally wired libraries ?!!!

naazgull
naazgull
12 years ago

You may try this solution, if you don’t mind your to get you desktop and gtk theme messed with. I tried and rolledback. Installed 2.7.5 from sources.